Billing System Outage
Incident Report for Intergrid
Resolved
This incident has been resolved.
Posted Apr 15, 2021 - 15:01 AEST
Update
The billing system is now operational.
Posted Apr 15, 2021 - 15:00 AEST
Investigating
We are aware of an outage affecting the billing system for Intergrid.
Engineers are investigating the cause of the issue.
We apologise for any inconvenience caused.
Posted Apr 15, 2021 - 13:37 AEST
This incident affected: Service desk.